Spore needs Leopard?

June 17, 2008

I finally got to download one of the two biggest downloads for the day – Spore Creature Creator. After looking at a couple of YouTube vides of the creator, both me and my little one have been dying to try out the creator. But alas, after the huge download completed, the installer quit saying Spore needs 10.5.3. What a shame?

Man, I have been pushing off getting that Leopard, but with each Leopard-only app, my resolve is weakening.

I guess I will have to make to do with my Windows box for Spore.

Advertisements

2 Responses to “Spore needs Leopard?”

  1. Josh Says:

    yeah i was pretty bummed about this as well….!

  2. Cape Says:

    Just another way for Apple to strongarm you into upgrading to their buggy OS.

    Apple keeps losing points with me almost daily.

    -1


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: